Wednesday, October 26, 2011

Mod me do!

I've had an odd few weeks or two and no mistake.
Due to a snafu with ebay (involving a parcel making an unexpected and frankly reasonless trip to Lima) I've found myself with two megadrives.Where as previsouly I was lacking in the megadrive 1 department , I am now overflowing. Rather than doing the anything sensible like , you know , selling one and making my wife happy, or trading it, I instead decided to modify one, kepping the other one as a spare.I wanted to have an uber setup that would run any cartridge I threw at it.
Well... Sega cartridge obviously.
The first part , which involved widening the cart slot wasnt too bad .Much hacking , and scraping and cutting , and after I'd bandaged my hands and wiped up the blood, I had a machine that still looked decent enough and would take the slightly wider Japanese cartridges.
The second part , the part that would show me as the uber modder that I am involved fitting two switches to the side of the machine , one to change it from 50/60hz , the other to force it between japanese and english language .Both are essential to playing import games properly.
Making the holes for the first piart wasnt too bad, although the jerry rigged drill setup I used didnt go 100 percent correctly (I'm pretty sure the skin on my thumb will grow back , although it makes typing this a lot harder .Thank God for spellchecks , thats all I can say),and eventually I got a bit gung ho and just used the side of the soldering iron to melt the slots for the switches into the side of the unit.This worked out quite well , although the computer room still smells like of burnt plastic a week later.I'd picked up two switches in maplin , and an old keyboard cable which had the right amount of cored cables inside.After breaking the trace on two jumpers on the motherboard I was ready to go.
I 'd used a guide from mmonkey's guides , which involved a few less cables , a neater design and a bit less soldering.
It was perfect , or at least it would have if it had actually worked.
Sadly some thing had gone wrong somewhere and the machine refused to start.
Eventually I got some small cables , made mini jumpers out of them and soldered them where the cut traces had been .Success , the machine was starting now! Except its now running in 60hz mode!
It shouldnt!
But!
It!
Does!
It needs an RGB cable to work in colour though..doh!
I've decided to go back to the drawing board and restart this from scratch , with a less complicated switch design.Hopefully itll work
Oh and in other news I picked up 2 fake sega 6 button pads (they work fine but appear to be made out of the same plastic used for dog -chew-toys), and somehow got a Master system converter (the big one that sits ontop of the megadrive 1 ) for a fiver off ebay.Normally there 20-40 quid so I lucked out there .Its a good thing I have the spare meg to use them on!

Wednesday, October 12, 2011

ahh way too long between updates.Had a ton of stuff going on , and not much spare time.
Load of new updates over on the youtube channel. Finally finshed the outrun reviews , covering the msx/dos ps2 versions and having a crack at the arcade version.Did mini reviews of robocop2 chase hq on the c64 , granada on the meg and treasure island dizzy.
The current one up at the mo is Kings field , the rock hard precursor to dark souls

I covered the first part of a batman gaming retrospective over at www.gamersireland.ie too
I've the second part finished , I just have to get a chance to get it uploaded properly!
I'd a few background problems too . I'd gotten a new video capture device, and while it works fine , conicidentally I'd noticed that all the narration I recorded since was very lispy.I couldnt work out what was wrong, I dont talk with a lisp in real life , I changed the headset/rerecored in audacity , but it was still there.EVENTUALLY I worked out what had happened .I've a little usb cam on my desk .It has a mike built in (I hadnt realised this).When I first started recording youtube vids and doing recordings , I'd been using a headset , but windows had defaulted the microphone to the usb web cam one.Ironically it seems to be much better at recording my voice than the headset! Its a happy accident as if I'd heard the lispyness on the first few vids I would have given up making them!
Anything else? oh yeah I'm now the proud owner of 2 megadrive 1's .I'd bought one from a nice guy on ebay .I'd managed to get it "as is " and "possibly working" for 99p plus a tenner postage.The chap split it up into 3 parcels when sending , 1 for pads , 1 for psu and 1 for the meg.?Two of them arrived ..one (with the meg) didnt .Time passed , and in fairness to the guy he offered a full refund.JUST as I was going to drop him a mail and look for 2-3 quid back for the meg , it arrived.With a delivery docket showing it had ended up at LIMA airport .Thats in Peru. LIMA.PERU. My irish address was correct and readable.LIMA! No idea how the hell it got diverted to there.
Of course in the meantime I'd gone out and picked up a second MD 1 (I traded one of my many c64s for it).
So now I've two .One is probably going to be modded to run every region of MD cart , the other left pristine(and yeah probably traded for another console a few months from now).